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Chapter 44: Automation

Pro Tools features dynamic automation of mixing 
controls on each of the track types. You can write 
automation moves and view them in real time dur-
ing playback of your session. You can also edit au-
tomation data with the same techniques you use to 
edit audio and MIDI data.

Automation Accuracy with 
Control Surfaces

Control Surfaces D-Control, D-Command, Pro-
Control, C|24, Control|24, and Command|8 control 
surfaces (as well as the 003 and Digi 002 inte-
grated audio and MIDI interfaces with control sur-
faces for Pro Tools) support the automation fea-
tures in Pro Tools. Pro Tools control surfaces 
provide 10-bit resolution, or 1,024 steps of fader 
resolution. Pro Tools interpolates this input to 24-
bit resolution on playback, resulting in extremely 
accurate and smooth fader automation.

EUCON Avid control surfaces using EUCON pro-
vide 12-bit resolution fader and knob control.

MIDI Control Surfaces Most MIDI control sur-
faces have 7-bit resolution, or 128 steps. Pro Tools 
interpolates this input to 24-bit resolution on play-
back, resulting in accurate and smooth fader auto-
mation.

Automation Overview

Pro Tools provides many options for recording, re-
placing, and editing automation data. 

The basic steps for automation recording are:

• Enable the automation type that you want to re-
cord (volume, pan, mute, send level, send pan, 
send mute, or plug-in automation). 

• Put the appropriate tracks in an automation writ-
ing mode (Write, Touch, or Latch, or a Trim 
mode). 

• If you are automating a plug-in, enable the 
individual plug-in controls to be automated.

• Automation Safe any plug-ins, outputs, or sends 
that have existing automation data that you want 
to protect from being overwritten. 

• Begin playback to begin automation recording, 
and adjust controls as needed. Pro Tools remem-
bers all moves performed on enabled controls. 

To edit automation once it has been recorded, you 
can:

• Repeat the above steps to write new automation 
over the previous data.

• Graphically edit the automation data in the Edit 
window.

• Cut, copy, paste, or delete automation data (cer-
tain restrictions apply).

For details on using control surfaces to 
create mix automation, see your control 
surface guide.
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Automation Playlists

Each Pro Tools track contains a single automation 
playlist for each automatable parameter.

On audio tracks, these parameters include:

• Volume

• Volume Trim (Pro Tools HD and Pro Tools with 
Complete Production Toolkit only)

• Pan

• Mute

• Send Level

• Send Level Trim (Pro Tools HD and Pro Tools 
with Complete Production Toolkit only)

• Send Pan

• Send Mute

• Plug-In controls

On Auxiliary Input tracks, these parameters in-
clude:

• Volume

• Volume Trim (Pro Tools HD and Pro Tools with 
Complete Production Toolkit only)

• Mute

• Pan

On Master Faders, these parameters include:

• Volume

• Volume Trim (Pro Tools HD and Pro Tools with 
Complete Production Toolkit only)

• On MIDI tracks, these parameters include:

• MIDI Volume

• MIDI Pan

• MIDI Mute

On Instrument tracks, these parameters include:

• Volume (audio)

• Volume Trim (audio) (Pro Tools HD and 
Pro Tools with Complete Production Toolkit 
only)

• Mute (audio)

• Pan (audio)

On VCA Master tracks (Pro Tools HD and 
Pro Tools with Complete Production Toolkit 
only), these parameters include:

• Volume

• Volume Trim

• Mute

You can display and edit each of these automatable 
playlists individually from Pro Tools, even during 
playback.

In addition, on MIDI and Instrument tracks you 
can display and edit other continuous MIDI con-
troller data (such as mod wheel, breath controller, 
foot controller, or sustain) in a similar manner. For 
more information on editing MIDI data, see “Con-
tinuous Controller Events” on page 694.
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Automation Playlists with Audio 
and MIDI Clips

Pro Tools handles audio clips and their automation 
playlists differently from MIDI clips and their au-
tomation playlists.

Audio Tracks

On audio tracks, automation data resides on a sep-
arate playlist from audio data and clips. Each edit 
playlist on an audio track shares the same automa-
tion data. 

MIDI and Instrument Tracks

On MIDI tracks and Instrument tracks, all control-
ler automation data except for MIDI Mute data, or 
audio mute (Instrument tracks only), is stored in 
the MIDI clip that contains it. Each edit playlist on 
the track is separate, and represents a distinct per-
formance, complete with controller automation. 

Trim Automation Playlists
(Pro Tools HD and Pro Tools with Complete 
Production Toolkit Only)

Separate Trim automation playlists are available 
for Volume trim and Send Level trim. Volume trim 
is available on all track types except MIDI tracks. 
Send Level trim is available on audio tracks only. 

Each Trim automation playlist shows the position 
of the Trim fader with yellow breakpoint automa-
tion that can be edited. For more information on 
Trim playlists, see “Trim Mode” on page 1024 and 
“Viewing Automation” on page 1028. 

Multiple Edit Playlists and Audio 
Track Automation 

All edit playlists on a single audio track share the 
same automation data. When you record or edit au-
tomation data in an audio track, the automation 
data is stored in the track’s corresponding automa-
tion playlist so it can be edited with, or indepen-
dently from, its associated audio clips. 

� When you copy or cut audio data from a track 
while it is in Waveform view, the underlying auto-
mation data is cut or copied with it. 

� If you paste audio data from other locations or 
tracks into an edit playlist, you may change the un-
derlying automation data on the track. 

� When you trim clips using Edit > Trim, the un-
derlying automation data remains unchanged. 

Duplicating Tracks for Playlist 
Editing

The Duplicate Track command provides a conve-
nient way to make a working copy of a track to ex-
periment with routing, plug-ins, and automation. 
This protects the original track and its automation 
data from being edited or overwritten. 

MIDI Mute data is independent of the 
MIDI data in a MIDI clip. This lets you 
mute playback of individual MIDI or 
Instrument tracks in Pro Tools without 
altering the controller data. 

MIDI continuous controller data always 
follows clip editing, with the exception of 
mute. See “MIDI and Instrument Tracks” 
on page 1021 for more information.

For more information, see “Editing 
Automation” on page 1047.

For more information on duplicating tracks 
command, see “Duplicating Tracks” on 
page 229.
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Automation Modes

Automation modes control how a track’s automa-
tion data is written and played back. Each track 
provides an Automation Mode selector for select-
ing the track’s Automation mode.

Off Mode

Off mode turns off automation for all automatable 
parameters:

• Volume

• Pan

• Mute

• Send volume, pan, and mute

• Plug-In controls

• MIDI volume, pan, and mute

In Off mode, automation data for these parameters 
is ignored during playback. All other MIDI con-
troller data is sent. 

Automation can be switched from Off to another 
Automation mode during playback or record.

Read Mode

Read mode plays any automation that was previ-
ously written for a track.

Write Mode

Write mode writes automation from the time play-
back starts to the time it stops, erasing any previ-
ously written automation for the duration of the au-
tomation pass. 

AutoMatch can be applied to a Write automation 
pass. See “AutoMatch Time” on page 1027.

“After Write Pass, Switch To” Option

You can set Pro Tools to automatically change to 
Touch mode or Latch mode, or remain in Write 
mode after the completion of an automation pass in 
Write mode.

To set the Automation mode after a Write pass:

1 Choose Setup > Preferences and click Mixing.

2 Under Automation, select an After Write Pass, 
Switch To option (Touch, Latch, or No Change).

3 Click OK to close the Preferences window.

Touch Mode

Touch mode writes automation only while a fader 
or switch is touched or clicked with the mouse. 
When the fader is released, the writing of automa-
tion stops and the fader returns to any previously 
automated position, at a rate determined by the Au-
toMatch and Touch Timeout settings. See “Auto-
mation Preferences” on page 1026.

In Touch mode, certain control surfaces start writ-
ing automation as soon as you touch them. These 
include touch-sensitive fader controllers, such as 
D-Control, D-Command, ProControl, C|24, 003, 
Digi 002, or Command|8.

With other control surfaces in Touch mode, writ-
ing of automation does not begin until the fader 
hits the pass-through point, or the previously auto-
mated position. Once you reach the pass-through 
point with the fader, or a non-touch sensitive rotary 
control, writing of automation begins and contin-
ues until you stop moving the fader.
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Latch Mode

Latch mode works in the same way as Touch 
mode, writing automation only if you touch or 
move a control. However, unlike Touch, writing of 
automation continues until you stop playback or 
“punch out” of the automation pass by changing 
the Automation mode to Read or Touch.

AutoMatch can be applied to a Latch automation 
pass. See “AutoMatch Time” on page 1027.

Latch mode is particularly useful for automating 
Pan controls and plug-ins on non-touch sensitive 
rotary controls, since it does not time out and revert 
to its previous position when you release a control. 

AutoJoin with Latch Mode
(Pro Tools HD and Pro Tools with Complete 
Production Toolkit Only)

Pro Tools provides two different methods to 
resume writing automation on controls that were 
active at the point where the transport stopped:

AutoJoin Lets you automatically resume writing 
automation in Latch mode.

Join Lets you manually resume writing automa-
tion in Latch mode. Join is available only with sup-
ported control surfaces.

To enable AutoJoin from Pro Tools:

1 Choose Window > Automation.

2 Click the AutoJoin button.

See also “Writing Automation to the Start, 
End, or All of a Track or Selection” on 
page 1058.

AutoJoin Enable button in the Automation window

See your control surface guide for details on 
using Join and AutoJoin with a control surface.
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AutoJoin Indicator

After a Latch automation pass with AutoJoin 
enabled, the AutoJoin indicator appears in the 
Pro Tools Edit window.

The AutoJoin indicator is a vertical line that signi-
fies the point where the last automation pass was 
stopped, and the point where the “join” will auto-
matically occur on all tracks that were writing dur-
ing that previous pass. When automation writing is 
resumed from this point, the line disappears.

Touch/Latch Mode
(Pro Tools HD and Pro Tools with Complete 
Production Toolkit Only)

Touch/Latch Automation mode places a track’s 
Volume control in Touch mode and all other auto-
matable controls in Latch mode. 

In Touch/Latch mode, the Volume control follows 
Touch behavior, writing automation when touched 
and returning to previously written levels when re-
leased. 

All other controls follow Latch behavior, writing 
automation when touched and continuing until 
playback stops, or until you punch out of writing 
automation.

Trim Mode
(Pro Tools HD and Pro Tools with Complete 
Production Toolkit Only)

Pro Tools HD can adjust (or trim) existing track 
volume and send level automation data in real 
time. Pan, mute and plug-in automation cannot be 
trimmed in this manner. Trim mode works in com-
bination with the other Automation modes (Read, 
Touch, Latch, Touch/Latch, and Write) and is use-
ful when you want to preserve all of your volume 
automation moves, but need to make levels a bit 
louder or softer to balance a mix. For more infor-
mation, see “Trim Automation Modes” on 
page 1025.

AutoJoin indicator in the Edit window

To use Join or AutoJoin to resume writing 
on controls that were writing when the 
transport stopped, restart the transport be-
fore the AutoJoin indicator.

Selecting Touch/Latch mode
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When writing automation in Trim mode, fader 
moves write relative rather than absolute values. 
The existing automation data is changed by the 
amount of increase or decrease (or the delta value) 
indicated by the faders. 

When Trim mode is enabled, non-trimmable con-
trols behave in the same manner as in the standard 
Automation modes, with the exception of 
Write/Trim mode, where non-trimmable controls 
operate as in Touch mode.

Trim Automation Modes

When a track is in a Trim automation mode (except 
for Trim Off) its main Volume faders and all Send 
level faders are displayed in yellow. When trim-
ming, a track’s Volume indicator or Send Level in-
dicator shows the delta value being written rather 
than the absolute value.

Behavior of the Trim Automation modes also de-
pends on the Coalesce Trim Automation prefer-
ence setting. See “Coalescing Trim Automation” 
on page 1057. 

Trim Off

Trim Off turns off reading and writing of all auto-
mation (main and trim) for a track. All automation 
moves are ignored during playback. Trim faders 
are temporarily set to zero when a track is set to 
Trim Off mode.

Depending on the Coalesce Trim Automation pref-
erence setting, changing a track to Trim Off can 
coalesce Trim automation on that track. See “Co-
alescing Trim Automation” on page 1057. 

Automation can be switched from Trim Off to an-
other Automation mode during playback or record.

Read Trim

In Read Trim mode, Volume and Send level Trim 
faders are disengaged from the main automation 
playlist and follow any existing Trim automation. 
You can move a Trim fader during playback to au-
dition new trim values, but no automation is writ-
ten. When the Trim fader is released, it returns to 
any previously written Trim automation values.

If a track does not contain Trim automation, you 
can move a Trim fader during playback to audition 
new trim values, but no automation is written. The 
Trim fader retains its position until the track is re-
moved from Trim mode, or if you manually co-
alesce the Trim level.

When this mode is enabled, non-trimmable con-
trols (all controls other than track volume and send 
level) behave as if they are in regular Read mode—
no automation data is written.

Touch Trim

In Touch Trim mode, Volume and Send level Trim 
faders are disengaged from the main automation 
playlist and follow any existing Trim automation. 
When a Trim fader is touched, writing of Trim au-
tomation begins. When the fader is released, writ-
ing stops and the fader returns to any previously 
written Trim automation values.

The rate of the fader’s return to previous trim val-
ues is determined by the AutoMatch Time speci-
fied in the Automation Preferences page. See “Au-
toMatch Time” on page 1027 for more 
information.

When this mode is enabled, non-trimmable con-
trols (all controls other than track volume and send 
level) behave as if they are in regular Touch 
mode—they follow the previously written automa-
tion until touched. When they are touched, their 
absolute positions are written until the control is 
released or until playback stops. 
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Latch Trim

In Latch Trim mode, Volume and Send level Trim 
faders are disengaged from the main automation 
playlist and follow any existing Trim automation. 
When a Trim fader is touched, writing of Trim au-
tomation begins. Writing of Trim automation con-
tinues until playback stops, or until you punch out 
of writing automation. 

When this mode is enabled, non-trimmable con-
trols (all controls other than track volume and send 
level) behave as if they are in regular Latch 
mode—they follow the previously written automa-
tion until touched. When they are touched, their 
absolute positions are written until playback is 
stopped.

Touch/Latch Trim

In Touch/Latch Trim mode, Volume and Send 
level faders are disengaged from the main automa-
tion playlist and follow any existing Trim automa-
tion. The main Volume Trim fader follows Touch 
Trim behavior, and Send level Trim faders follow 
Latch Trim behavior. 

Write Trim

In Write Trim mode, as soon as playback begins, 
writing of Trim automation begins for Volume and 
Send levels, and continues until playback stops, or 
until you punch out of writing automation.

When Write Trim mode is enabled, non-trimmable 
controls (all controls other than track volume and 
send level) are not in Write mode, but behave as if 
they are in regular Touch mode (no automation is 
written unless a control is touched). This is to pre-
vent the controls from overwriting all of their au-
tomation data on every pass in Write Trim mode.

Automation Preferences

Pro Tools gives you several options for controlling 
the writing and playback of automation data.

To display Automation preferences:

� Choose Setup > Preferences and click Mixing.

The “After Write Pass, Switch To” prefer-
ence affects Write Trim mode. After an au-
tomation pass in Write/Trim mode, tracks 
automatically switch to the Trim mode ver-
sion of the setting specified by this prefer-
ence.

Mixing Preferences page

For detailed information on Pro Tools Au-
tomation preferences, see “Mixing Prefer-
ences” on page 135.
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Send Levels and Trim Mode
(Pro Tools HD and Pro Tools with Complete 
Production Toolkit Only)

You can set Pro Tools to exclude Send levels from 
Trim mode, so that only the Main Volume goes 
into Trim when a track is put into Trim mode. This 
gives you more flexibility in setting Send levels 
while in Trim mode.

To exclude Send levels from Trim mode:

1 Choose Setup > Preferences and click Mixing.

2 Under Automation, deselect Include Sends in 
Trim Mode.

3 Click OK.

Smoothing

When you perform automation moves (including 
Trim moves) with a continuous control, Pro Tools 
records the move as a series of very small steps, re-
sulting in a staircase pattern with many break-
points. Smoothing intelligently resolves this stair-
case pattern into a single, smooth ramp from one 
breakpoint to the next. (Smoothing does not apply 
to switched controls such as mutes or plug-in by-
passes.) With smoothing enabled, the resulting au-
tomation data is often a more accurate representa-
tion of actual automation moves. 

Thinning

Thinning automatically reduces the overall num-
ber of breakpoints in an automation playlist (in-
cluding Trim playlists) in order to improve system 
performance. The amount of thinning applied is 
determined by the Degree of Thinning setting in 
the Automation Preferences page. When using 
high amounts of thinning, the resulting automation 
may differ noticeably from the original automation 
moves. Thinning only applies to audio tracks, and 
does not affect MIDI tracks. For instructions, see 
“Thinning Automation” on page 1045.

AutoMatch Time

AutoMatch Time is the amount of time it takes for 
a fader to return (by ramping up or down) to the 
level of automation still on the track as the automa-
tion pass ends. This time value is set in the Auto-
mation Preferences page (see “Automation Prefer-
ences” on page 1026).

AutoMatch is automatically applied to all Touch 
mode passes, and can be applied to Latch or Write 
passes.

The AutoMatch Time also determines the rate at 
which delta values written with the Trim will re-
turn to 0 dB (delta value of zero).

The AutoMatch feature works with continuous 
controls (such as Volume or Pan) by ramping their 
values back to previously automated levels. There 
are some stepped controls (for example, the EQ 
type in the 1-band EQ plug-in) that provide more 
than two discrete steps over their operational 
range. AutoMatch has no effect on these controls.

Any uncoalesced automation on a Send will 
still coalesce when the other automation on 
its track is coalesced, even if “Include Sends 
in Trim Mode” is deselected.
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Automation Follows Edit Option

When disabled, automation events are not affected 
by edits to audio or MIDI notes. When enabled, au-
tomation events are affected by edits to audio or 
MIDI notes.

To enable or disable Automation Follows Edit, do 
one of the following:

� Select or deselect Options > Automation Follows 
Edit.

� Click the Automation Follows Edit indicator in 
the Edit window toolbar. The indicator is high-
lighted when enable and not highlighted when it 
is disabled.

Automation Safe 

Outputs, sends, and plug-ins can be placed in Au-
tomation Safe mode. In Automation Safe mode, 
any automation associated with an Output window 
(such as track or send level, panning, or mute), or 
plug-in on that track, is protected from being over-
written while automating other items on that track. 

Automation Safe mode suspends automation re-
cording for the selected track output, send, or plug-
in that is enabled. You can also suspend automa-
tion recording and playback session-wide from the 
Automation window. See “Enabling and Suspend-
ing Automation” on page 1042. 

Viewing Automation

Pro Tools creates a separate playlist in the Edit 
window for each type of automation in a track, in-
cluding a playlist for each type of Trim automa-
tion. This data can be viewed and edited in the 
same way as audio and MIDI data. You can either 
change Track Views to show the automation you 
want, or you can reveal an Automation lane under 
the track regardless of its Track View.

Automation Follows Edit indicator in the Edit window

Automation Safe enabled send

You can easily toggle between different Track 
Views. See “Changing Track Views” on 
page 233.


